پوشش حفره امنیتی هسته لینوکس توسط گوگل

|
۰ دیدگاه
cyber-security

ضرورت نصب مجدد اندروید برای از بین بردن حفره‌ای که هک راه را برای روت کردن برنامه‌ها باز می‌کند، احساس می شود.

به گزارش کلیک، گوگل به تازگی اعلام کرده که یک حفره امنیتی در اندروید را می‌بندد که تحت تسلط دستگاه‌های راه دور فعال شده است. این نقطه ضعف (CVE-2015-1805) تمام دستگاه‌های اندروید در حال اجرا بر روی کرنل لینوکس زیر ۳٫۱۸ را تحت تاثیر قرار خواهد داد.

این حفره امنیتی، یک امتیاز حیاتی به هکرها می‌دهد که برنامه‌ها، کدهای اختیاری را در کرنل اجرا کنند. کاربران آسیب دیده باید سیستم عامل اندروید را فلش کنند. در همین ارتباط، گوگل یک برنامه روت پیدا کرده است که از این نقطه ضعف برای روت کردن نکسوس۵ و هندست۶ استفاده می‌شود.

شرکت آلفابت نگفت که آیا این برنامه مخرب است یا به کاربران کمک می‌کند تا دستگاه نکسوس خود را روت کنند.

گوگل این برنامه روتینگ را در پلی استور خود مسدود کرده است، در حالی که کاربران جدیترین سیستم عامل اندروید هشدارهای امنیتی در مورد قابلیت روت کردن دریافت می‌کنند. ابن غول جستجو، ۱۵ مارس یک پچ برای شرکای سازنده تلفن پیش از پخش عمومی آن ارسال کرده است.

این کمپانی اعلام کرد گوگل از برنامه‌های روتینگ در یک ارزیابی آسیب‌پذیری در دستگاه‌های اندروید مطلع شد. این یک مساله شناخته شده در کرنل لینوکس است که در آوریل ۲۰۱۴ ترمیم شد اما از آن با عنوان یک ترمیم امنیتی نام برده نمی‌شود.

در ۱۶ فوریه ۲۰۱۶ تیم C0RE به گوگل اطلاع داد که این مساله ممکن است باعث ایجاد اکسپلویت در اندروید شود و در همین ارتباط یک پچ طراحی شد تا به طور منظم در به‌روز رسانی ماهانه گنجانده شود.

منبع: theregister

0 پسندیده شده
مهرنوش چمنی
از این نویسنده

بدون دیدگاه

جهت ارسال پیام و دیدگاه خود از طریق فرم زیر اقدام و موارد زیر را رعایت نمایید:
  • پر کردن موارد الزامی که با ستاره قرمز مشخص شده است اجباری است.
  • در صورتی که سوالی را در بخش دیدگاه مطرح کرده باشید در اولین فرصت به آن پاسخ داده خواهد شد.